Back to overview
Resolved

SSL certificates for *.baserow.site domains are delayed

Sep 9, 2026 at 9:13am UTC
Affected services
Frontend

Resolved
Sep 9, 2026 at 9:13am UTC

If you publish an application to a *.baserow.site domain, then there can be a delay before the SSL certificate is issued. This results in a "The connection has timed out" error. It can take up to 24 hours before it works.